Motto

Každá síť je taková, jaký je její administrátor.

Navigace:   Úvod Rady - tipy - triky Vychytávky v Linuxu Repozitáře pro starou verzi Ubuntu 6.10
Repozitáře pro starou verzi Ubuntu 6.10 PDF Tisk Email
Čtvrtek, 07 Srpen 2008 09:14

Pokud používáte nějakou starší verzi Ubuntu, která již není oficiálně podporovaná, pak jste museli narazit na problém při instalaci nějakého balíčku. Podpora na každou verzi Ubuntu je 1,5 roku, výjimkou jsou verze označené LTS, ty mají podporu 3 roky na desktopech a 5 let na serverech. Když jste z nějakého důvodu (např. z důvodu plné spokojenosti) zůstali věrni jedné verzi, pak po uplynutí této doby nemůžete instalovat software ze stejných repozitářů. Repozitáře nepodporovaných verzí jsou přesunuty na jiný server. Čili není nic ztraceno, stačí jenom upravit seznam zdrojů a vše bude fungovat dále a stejně. Spusťte si textový editor s rootovskými právy:

  • $ gksu gedit /etc/apt/sources.list

Otevřte si soubor /etc/apt/sources.list a v něm upravte adresu serveru původních zdrojů (staré nemusíte hned mazat, stačí zakomentovat):

  • #deb http://cz.archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
  • #deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
  • deb http://old-releases.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
  • deb-src http://old-releases.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
  • #deb http://cz.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
  • #deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
  • deb http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
  • deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
  • #deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
  • #deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
  • deb http://old-releases.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
  • deb-src http://old-releases.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

A nakonec zaktualizujte seznam balíčků buď grafickým správcem nebo příkazem v konzole:

  • $ sudo apt-get update (popř. su -c apt-get update)

Pozn. autora: Nevím, jestli vydávat dvě verze Ubuntu ročně, je krok správným směrem.

 
Mendelovo gymnázium | Designed by webmaster | Powered by Joomla | Creative Commons Attribution